Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 06, 2025 - 07:00 GMT
Update
Essential maintenance planned for mobile app based identity proving service using driving licence on Monday 6th January 2025 between 07:00 hrs and 08:00 hrs. During this period, users may experience issues while trying to use a driving licence on the mobile app. As soon as the maintenance is complete at 08:00 hrs, normal service will be resumed.
Posted Jan 03, 2025 - 16:54 GMT
Update
We will be undergoing scheduled maintenance during this time.
Posted Jan 03, 2025 - 16:53 GMT
Scheduled
Essential maintenance planned for mobile app based identity proving service using driving licence on Monday 6th January 2025 between 07:00 hrs and 08:00 hrs. During this period, users may experience issues while trying to use a driving licence on the mobile app. As soon as the maintenance is complete at 08:00 hrs, normal service will be resumed.
Posted Jan 03, 2025 - 16:49 GMT
This scheduled maintenance affected: Identity proving (Identity proofing and verification, Mobile app identity checks).